BNZ Internet Banking outage

Incident Report for BlinkPay

Resolved

BNZ service is back online
Posted Mar 16, 2025 - 17:00 NZDT

Update

BNZ internet banking is currently experiencing downtime, for more information please check: https://status.bnz.co.nz
Posted Mar 16, 2025 - 14:01 NZDT

Identified

BNZ internet banking is currently experiencing downtime, for more information please check: https://status.bnz.co.nz
Posted Mar 16, 2025 - 14:00 NZDT
This incident affected: BNZ.