BlinkPay network error

Incident Report for BlinkPay

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 19:04 NZDT

Monitoring

Changes have been deployed to reduce the impact of the identified DNS propagation issue. We are closely monitoring for any continued errors.

We advise customers still having issues with making payments in our gateway to clear their browser cache and retry their payment.
Posted Mar 21, 2025 - 16:51 NZDT

Investigating

We are currently investigating this issue.

We advise customers having issues with making payments in our gateway to clear their browser cache and retry the payments.
Posted Mar 21, 2025 - 14:02 NZDT
This incident affected: Blink PayNow.