BNZ Downtime

Incident Report for BlinkPay

Resolved

Service has been restored. See https://status.bnz.co.nz for more information.
Posted Jun 09, 2026 - 15:30 NZST

Identified

BNZ transactions are currently stuck and are unlikely to complete processing until this issue is resolved.
Posted Jun 09, 2026 - 15:17 NZST
This incident affected: BNZ.