Unexpected downtime

Incident Report for BlinkPay

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 14:29 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 14:22 NZST

Identified

We are currently working on the issue.
Posted Apr 21, 2026 - 14:11 NZST
This incident affected: Blink PayNow, Blink AutoPay, and Blink Data.