High error rates

Incident Report for BlinkPay

Resolved

The issue turned out to be a user-browser based DNS issue and automatically resolved with global DNS propagation.
Posted Mar 20, 2025 - 20:32 NZDT

Investigating

We are investigating higher error rates than usual for bank payments. Our team is working to resolve the issue.
Posted Mar 20, 2025 - 20:22 NZDT
This incident affected: Blink PayNow.