Westpac Service Disruption
Incident Report for BlinkPay
Resolved
Service has been restored. See https://status.westpac.co.nz for more information.
Posted Nov 17, 2024 - 05:00 NZDT
Identified
Please see https://status.westpac.co.nz for more information on the incident.
Posted Nov 17, 2024 - 02:00 NZDT
This incident affected: Banks (Westpac).