BNZ Service Disruption
Incident Report for BlinkPay
Resolved
Service has been restored. See https://status.bnz.co.nz for more information.
Posted Nov 17, 2024 - 04:00 NZDT
Identified
Please see https://status.bnz.co.nz for more information on the incident.
Posted Nov 17, 2024 - 01:00 NZDT
This incident affected: Banks (BNZ).