BNZ Online banking down
Incident Report for BlinkPay
Resolved
BNZ has restored functionality
Posted Oct 12, 2024 - 17:18 NZDT
Identified
BNZ Online banking is currently down and as as a consequence BNZ payments cannot currently be processed through our service.
Posted Oct 12, 2024 - 16:12 NZDT
This incident affected: Blink PayNow and Bank Partners (replaced).