ANZ payment processing issue

Incident Report for BlinkPay

Resolved

This incident has been resolved.
Posted May 07, 2026 - 17:52 NZST

Identified

An issue with ANZ payment completion has been identified. Our team is on it.
Posted May 07, 2026 - 15:11 NZST
This incident affected: ANZ.