Third party service outage preventing payment completion
Incident Report for BlinkPay
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 13:14 NZDT
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2024 - 13:01 NZDT
Identified
The issue has been identified and a fix is in progress. Please try again in a few minutes.
Posted Nov 20, 2024 - 11:37 NZDT
This incident affected: Blink PayNow.